Your program may be attempting to use an archived openmpi installation. Check your application to make sure it is using one of the openmpi installations located in the /util/common/openmpi area.